404 error on production
Incident Report for Productboard
Resolved
We are up and running! We will continue to monitor over the next few hours.
Posted Dec 16, 2019 - 17:25 UTC
Investigating
We are currently investigating a 404 error - we will keep you updated here. Thanks for your patience.
Posted Dec 16, 2019 - 17:10 UTC