Currently investigating a Portal issue with submit vote/idea buttons
Incident Report for productboard
Resolved
This incident has been resolved.
Posted Jul 07, 2020 - 19:17 UTC
Update
Waiting for the fix to be deployed shortly.
Posted Jul 07, 2020 - 18:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 07, 2020 - 17:13 UTC
This incident affected: Web application.