404 error on production
Incident Report for productboard
Resolved
The issue has been resolved.
Posted Jan 21, 2020 - 16:48 UTC
Update
We are continuing to investigate this issue.
Posted Jan 21, 2020 - 16:43 UTC
Investigating
We are currently investigating a 404 error.
Posted Jan 21, 2020 - 16:42 UTC