Premium Features not visible
Incident Report for productboard
Resolved
This incident has been resolved.
Posted Mar 12, 2021 - 21:46 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 12, 2021 - 16:43 UTC
Monitoring
Update: Above incident has now been resolved. The team will keep on monitoring the data. Please contact support@productboard.com if you face any relevant issues.
Posted Mar 12, 2021 - 16:42 UTC
Investigating
We noticed an issue with some premium features not being visible to customers (Insights Board or Portal). The team is currently investigating, thank you for your patience.
Posted Mar 12, 2021 - 15:49 UTC
This incident affected: Web application.