Unable to sign up for new or existing projects
Incident Report for Productboard
Resolved
The issue was resolved once again, thanks so much for bearing with us :)
Posted Oct 14, 2019 - 12:01 UTC
Investigating
We still have issues with the signup for few users. We apologize, the issue is more complex that we originally estimated. We are going to keep you updated on the resolution.
Posted Oct 14, 2019 - 11:15 UTC