New boards types (Beta) are not loading
Incident Report for Productboard
Resolved
This issue has now been resolved. You should now be able to load all new board types. Thank you for your patience and understanding.
Posted Jun 27, 2024 - 16:47 UTC
Identified
Customers are unable to load new board types (Grid, Timeline - Beta) in their workspace. The issue is identified and our team is working on a fix. Non-Beta Feature boards and Roadmaps should not be affected.
Posted Jun 27, 2024 - 15:16 UTC
This incident affected: Web application.