Application stopped loading
Incident Report for Productboard
Resolved
This incident has been resolved. Thanks once again for your understanding.
Posted Sep 29, 2021 - 15:41 UTC
Update
All the public portals are working correctly now. Please don’t hesitate to reach out to us at support@productboard.com in case of any questions or concerns. Thanks for your patience.
Posted Sep 29, 2021 - 15:25 UTC
Update
We have identified an issue with some public portals not working correctly, and we’re working on a fix.

In the meantime, we are continuing to monitor for any further issues. If you have any questions or concerns, please don’t hesitate to reach out to us at support@productboard.com. Thank you for your patience and understanding.
Posted Sep 29, 2021 - 14:39 UTC
Monitoring
We encountered an outage issue earlier today that affected all the accounts. We have rectified the underlying problem and you should be up and running again now. We are currently monitoring the performance, please feel free to let us know if you notice any kind of unusual behaviour.
If you have any questions, please don’t hesitate to give us a shout at support@productboard.com
Posted Sep 29, 2021 - 13:39 UTC
Update
We’re really sorry to be holding you up today! Please know our teams are working hard to get everything up and running, and we will update you again shortly with the latest information. Thank you for your understanding.
Posted Sep 29, 2021 - 12:27 UTC
Update
Thank you for your patience and understanding as we work to fix the error that is causing this outage. We apologize this is taking longer than expected and we assure you that the team is fully focused on bringing Productboard up and running as quick as possible!
As we work out a solution, we will be providing updates for all of our customers here and of course feel free to contact support@productboard.com if you have any further questions.
Posted Sep 29, 2021 - 11:36 UTC
Identified
We have identified the root cause, and we are working on a fix. Thanks for your patience.
Posted Sep 29, 2021 - 10:42 UTC
Update
We are continuing with our investigation and trying to identify the root cause of this downtime. We appreciate your understanding.
Posted Sep 29, 2021 - 10:00 UTC
Investigating
We are experiencing downtime. We are investigating the issue and will update you as soon as possible. We apologize for the inconvenience.
Posted Sep 29, 2021 - 09:19 UTC
This incident affected: Web application.