Scheduled Database Maintenance
Scheduled for May 11, 07:00 - 08:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 26, 2024 - 16:59 UTC
Scheduled
We will be undergoing scheduled maintenance on May 11 2024 at 7:00 am UTC. As a result, Productboard will not be available at this time.
Posted Apr 26, 2024 - 16:47 UTC
This scheduled maintenance affects: Web application.