Integrations Failing

Incident Report for Productboard

Resolved

This incident has now been resolved.
Posted Sep 12, 2025 - 14:19 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 12, 2025 - 14:18 UTC

Monitoring

We have mitigated the issue and are monitoring the results to see if this can be resolved.

Thank you for your patience today.
Posted Sep 12, 2025 - 13:15 UTC

Identified

We have identified the cause of the issue and are currently working on a fix.
Posted Sep 12, 2025 - 12:59 UTC

Investigating

We are currently investigating an issue where integrations might be failing working with Productboard.
Posted Sep 12, 2025 - 10:35 UTC
This incident affected: API and integrations.