Application not loading
Incident Report for productboard
Resolved
We took the necessary actions and we are pleased to announce that productboard is back up and running. We thank you for your patience and understanding.
Posted Jan 09, 2020 - 13:49 UTC
Investigating
We are experiencing downtime. We are investigating the issue and will update you as soon as possible. Sorry for the inconvenience!
Posted Jan 09, 2020 - 13:42 UTC