Issue delivering email caused by Mandrill
Incident Report for productboard
Resolved
We are still waiting for Mandrill to solve the issue. We will close the incident on our side, please check the status on Mandrill twitter: https://twitter.com/mandrillapp?lang=en. Sorry for the inconvenience!
Posted Feb 04, 2019 - 16:35 UTC
Investigating
It looks like Mandrill has an issue with delivering webhook request, so some emails may be delayed in appearing in your pb project. Hopefully this will be fixed soon on Mandrill side, please stay tuned!
Posted Feb 04, 2019 - 12:48 UTC
This incident affected: Email delivery.