Issues loading Productboard
Incident Report for Productboard
Resolved
All boards including Insights views should now be available and working as expected, though it's possible that customers may need to refresh their browser to access the data. We will continue to monitor the situation.

Thank you for your patience while we have worked on resolving this issue. If you are still encountering problems, please reach out to support@productboard.com.
Posted Jun 02, 2023 - 07:26 UTC
Update
All data for roadmaps and feature boards have now been restored. A browser refresh is needed. We continue to work on restoring the unavailable data on insights board. We thank you for your patience. Again, feel free to reach out to our support team at support@productboard.com with any further questions.
Posted Jun 01, 2023 - 23:09 UTC
Update
We apologize for the inconvenience caused. We are currently experiencing an issue with the unavailability of some of your data; affected are Views for Notes, Features board, and Roadmap. However, please note that the data displayed in these views remain accessible from other areas within the product.
Our team is actively working to restore access to the affected data and is investigating the root cause of this incident. We understand the importance of these views to your workflows.
We want to assure you that no data has been lost during this incident. Our team is diligently working to resolve the issue and restore full functionality as quickly as possible.
We will provide regular updates on the progress made and any further developments regarding this incident. We appreciate your patience and understanding.
Please feel free to reach out to our support team via email at support@productboard.com if you have any further questions or concerns.
Posted Jun 01, 2023 - 18:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2023 - 18:12 UTC
Update
We are continuing to investigate this issue.
Posted Jun 01, 2023 - 17:24 UTC
Update
We are continuing to investigate the issue.
Posted Jun 01, 2023 - 16:17 UTC
Investigating
Some users may be experiencing issues loading Productboard. We’re currently investigating the issue and will provide a status update once we have more information.
Posted Jun 01, 2023 - 15:23 UTC
This incident affected: Web application.