Delayed Data Propagation

Incident Report for Productboard

Resolved

Our engineers have reported this incident as mitigated - we are now resolving the incident.
Thank you for your patience and understanding during this time.
Posted Aug 01, 2025 - 09:28 UTC

Investigating

Our engineers are investigating an incident where there's a delay in data appearing on our new boards. We shall update this status page when we have made progress with this issue.
Apologies for the inconvience caused, hopefully we can get this sorted soon.
Posted Aug 01, 2025 - 08:54 UTC
This incident affected: Web application (Boards and data).