Productboard not loading
Incident Report for Productboard
Resolved
This incident has been resolved. Thanks again for your patience and understanding.
Posted Jan 10, 2022 - 16:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Thanks for your patience.
Posted Jan 10, 2022 - 16:07 UTC
Investigating
We are currently observing a slower response on Productboard, resulting in the application not loading correctly. We are looking into the issue and will provide you with an update as soon as possible. We apologize for the inconvenience.
Posted Jan 10, 2022 - 15:24 UTC
This incident affected: Web application.