Unable to register the account
Incident Report for productboard
Resolved
The issue is solved! Thanks for bearing with us and please try again :)
Posted Oct 14, 2019 - 09:43 UTC
Investigating
We are currently experiencing issues with the registration of the account, you may be unable to complete the operation and receive a "Oops, something has gone wrong" message. We are working very hard to fix it, sorry for the inconvenience
Posted Oct 14, 2019 - 09:37 UTC