Insights Boards not loading

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 16:40 UTC

Monitoring

The issue impacting Insights boards has now been mitigated and we're monitoring the situation.
Posted Nov 03, 2025 - 16:31 UTC

Identified

We are working to resolve degraded performance on insights boards. Users may experience delayed loading times or error messages.
Posted Nov 03, 2025 - 16:17 UTC

Update

We are continuing to investigate this issue.
Posted Nov 03, 2025 - 16:03 UTC

Investigating

We are currently investigating an issue where insights boards are not loading.
Posted Nov 03, 2025 - 15:53 UTC
This incident affected: Web application (Insights and AI).