We are experiencing a little degraded performance on Jira integrations
Incident Report for productboard
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 20:55 UTC
Identified
We are experiencing a little degraded performance on Jira integrations- No data is lost, processing of some JIRA issues is extremely slower than expected (for some cases it might take hours)
Posted Nov 19, 2020 - 20:48 UTC
This incident affected: Integrations & APIs.