Issues with Insights board
Incident Report for Productboard
Resolved
We have identified the issue and the team have pushed a fix. All Insights board features should be working as normal once more. If you encounter any issues, please reach out to support@productboard.com.
Posted Mar 28, 2023 - 10:40 UTC
Investigating
We're currently experiencing issues with the Insights board and we are investigating. This is impacting Topic detection, Notes automation, and Note views on the Insights board.

Once we have information to share we will update here immediately.
Posted Mar 28, 2023 - 10:35 UTC
This incident affected: Web application.