Changes made on boards taking too long to apply

Incident Report for Productboard

Resolved

The problem has been resolved, the system is back to normal operation.
Posted Sep 26, 2026 - 15:18 UTC

Monitoring

The system has mostly stabilized. Some customers may be still experiencing intermittent delays. We're monitoring the situation.
Posted Sep 26, 2026 - 14:05 UTC

Identified

Root cause identified: a single service overloaded a part of the system by generating large bursts of data.
Posted Sep 26, 2026 - 13:55 UTC

Investigating

We're currently experiencing a noticeable delay between the actions taken on boards or edits to entities to propagate throughout the system.
Posted Sep 26, 2026 - 13:47 UTC
This incident affected: Web Application.