Email delivery issues
Incident Report for Productboard
Resolved
We have resolved this issue. Emails are now being delivered.
Posted Nov 11, 2022 - 13:51 UTC
Update
We’re focused on getting things back to normal as quickly as possible. We apologise for the continued trouble. We’ll be back with another update soon.
Posted Nov 11, 2022 - 12:48 UTC
Identified
We have identified the issue and our team is working on a fix. We hope to get things back to normal as soon as possible. We will share an update soon.
Posted Nov 11, 2022 - 10:37 UTC
Update
We are continuing to investigate this issue.
Posted Nov 11, 2022 - 10:06 UTC
Update
We are continuing to investigate this issue.
Posted Nov 11, 2022 - 10:05 UTC
Investigating
We are experiencing issues with email delivery. Users may see issues with invitations and the email integration. We're investigating the issue and will provide a status update once we have more information.
Posted Nov 11, 2022 - 10:03 UTC
This incident affected: Email delivery.