In-app performance and Jira webhook issues

Incident Report for Productboard

Resolved

The issue was caused by a Cloudflare connectivity incident (https://blog.cloudflare.com/cloudflare-incident-on-august-21-2025). Service has been restored and remains stable, and we continue to monitor with our provider.
Posted Aug 21, 2025 - 19:24 UTC

Investigating

We’re investigating degraded in-app performance and Jira webhook sync delays that appear related to a Cloudflare connectivity issue affecting traffic between Cloudflare and AWS starting at 16:27 UTC on August 21, 2025.
Posted Aug 21, 2025 - 19:17 UTC
This incident affected: Web application (Boards and data) and API and integrations.