Productboard doesn't load
Incident Report for Productboard
Resolved
The productboard.com (main app) was unavailable for short periods of several minutes at 1:30 PM CEST, 2:15 PM CEST, and 3:15 PM CEST due to spikes in requests on the backend. The issue is completely mitigated now.
Posted Jun 19, 2024 - 15:12 UTC
Monitoring
The issue is mitigated and the team is currently monitoring it to ensure stability.
Posted Jun 19, 2024 - 14:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 19, 2024 - 12:06 UTC
Investigating
We're currently facing an issue with loading boards, which results in an "Uh oh! We had trouble loading the data" error. This is being investigated and we will provide a status update once we have more information.
Posted Jun 19, 2024 - 11:46 UTC
This incident affected: Web application.