Issues loading Productboard
Incident Report for Productboard
Resolved
We have identified the issue and the team has pushed a fix. Some customers may have to clear their cookies before this fix is available to them. If you are still encountering issues, please reach out to support@productboard.com. Thank you for bearing with us.
Posted Mar 06, 2023 - 17:44 UTC
Update
We are continuing to investigate this issue.
Posted Mar 06, 2023 - 17:24 UTC
Investigating
Some users may be experiencing issues loading Productboard. We’re currently investigating the issue and will provide a status update once we have more information.
Posted Mar 06, 2023 - 15:47 UTC
This incident affected: Web application.