UPDATE: Cloudfare (our CDN Provider) reporting network & resolving issues
Incident Report for productboard
Resolved
This incident has been resolved.
Posted Jul 18, 2020 - 03:44 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2020 - 21:45 UTC
Monitoring
We are monitoring the issue here: https://www.cloudflarestatus.com/
Posted Jul 17, 2020 - 21:42 UTC
This incident affected: Web application.