PB is down
Incident Report for productboard
Resolved
We are back up! Sorry for any disruption to your work.
Posted Nov 19, 2019 - 13:51 UTC
Investigating
PB is currently down. Our engineers are already working on it, really sorry about this. We will update you soon.
Posted Nov 19, 2019 - 13:44 UTC
This incident affected: productboard web application.