Intermittent errors causing Productboard to be unavailable
Incident Report for Productboard
Resolved
This incident has been resolved.
Posted May 17, 2023 - 16:16 UTC
Investigating
Productboard is currently experiencing errors intermittently causing some boards to be temporarily unavailable. Our team is investigating and will provide an update once additional information is available.
Posted May 17, 2023 - 15:57 UTC
This incident affected: Web application.