Mailchimp Maintenance
Incident Report for productboard
Resolved
Mailchimp has completed the maintenance. Emails from the app and email integrations are now working correctly. We appreciate your patience.
Posted Mar 04, 2020 - 17:06 UTC
Investigating
We are currently experiencing an issue with our email provider. This is affecting the delivery of emails from the app and might also affect any email integrations. We apologise for any inconveniences caused and hope to have the issue rectified shortly
Posted Mar 04, 2020 - 14:38 UTC
This incident affected: Email delivery.