Insight board performance issues

Incident Report for Productboard

Resolved

We have identified the issue and the team has pushed a fix. Insight board performance should be restored. If you are still encountering issues, please reach out to support@productboard.com. Thank you for bearing with us.
Posted Oct 21, 2025 - 20:37 UTC

Identified

We have identified the issue and our team is working on a resolution. We hope to get things back to normal as soon as possible. We will share an update soon.
Posted Oct 21, 2025 - 20:32 UTC

Investigating

We are investigating an issue affecting Insight Board performance. Notes are slow to load and analytics boards are timing out.
Posted Oct 21, 2025 - 20:16 UTC
This incident affected: Website (www.productboard.com).