System performance delays

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 18:32 UTC

Investigating

We are currently experiencing a temporary degradation in the platform affecting some customers. During this time, actions taken in the system may not appear immediately and could show up after a delay.

Our team is actively working to resolve the issue and restore normal performance. We’ll continue to provide updates as progress is made.
Posted Feb 23, 2026 - 17:29 UTC