New navigation loading issues
Incident Report for Productboard
Resolved
We have identified the issue and the team have pushed a fix. You should see that the views are now loading as expected.

If you are still encountering issues, please reach out to support@productboard.com. Thank you for bearing with us.
Posted Jun 01, 2023 - 12:12 UTC
Investigating
Some users may be experiencing issues loading Productboard views with the new navigation. We’re currently investigating the issue and will provide a status update once we have more information.
Posted Jun 01, 2023 - 11:37 UTC
This incident affected: Web application.