Google SSO outage
Incident Report for productboard
Resolved
This issue has been resolved: https://status.cloud.google.com/incident/developers-console/19008

Users can now login using Google SSO without any problems.
Posted Aug 19, 2019 - 20:48 UTC
Update
Google just reported a potential workaround:

"Some customers have reported success attempting to utilize an incognito window under the Chrome browser to login."
Posted Aug 19, 2019 - 19:37 UTC
Monitoring
Google is currently having an issue with SSO which is being tracked here: https://status.cloud.google.com/incident/developers-console/19008

As of now, our SSO login will not function. We will keep you updated once they have resolved it.

For those customers without Google SSO enforced, you can log in using your username and password.
Posted Aug 19, 2019 - 19:32 UTC
This incident affected: Integrations & APIs.