Password Reset Temporarily Unavailable
Incident Report for Productboard
Resolved
This incident has now been resolved. Thank you for your patience.
Posted Apr 27, 2023 - 20:09 UTC
Update
We are continuing to investigate this issue.
Posted Apr 27, 2023 - 20:08 UTC
Investigating
Resetting passwords is currently unavailable for all users. We apologize for any inconvenience caused by this issue. Our team is investigating and will provide further updates as soon as possible.
Posted Apr 27, 2023 - 19:45 UTC
This incident affected: Web application.