Database errors: some action may not be completed
Incident Report for productboard
Resolved
We’re happy to say we are monitoring the situation after deploying a number of significant performance fixes. We will open a new case if we encounter any new issues. Please let us know if you notice any slowdown in performance, and thanks so much for bearing with us! Sorry for any disruption of your work we caused
Posted Apr 09, 2019 - 17:16 UTC
Update
We are continuing to monitor for any further issues. We are very close to the resolution of the problem.
Posted Apr 09, 2019 - 12:29 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 08, 2019 - 18:46 UTC
Update
We are continuing to monitor for any further issues. Deleting/Updating features and columns may still not work.
Posted Apr 08, 2019 - 08:42 UTC
Update
Happy Sunday! We implemented a fix that should probably work. But we will know more over time. We are still monitoring the situation, we will update you on Monday.
Posted Apr 07, 2019 - 09:13 UTC
Update
We are still monitoring the situation, thank you for the patience!
Posted Apr 05, 2019 - 17:50 UTC
Update
We are still monitoring the situation, thank you for the patience to this point!
Posted Apr 05, 2019 - 15:04 UTC
Monitoring
We’re just deploying another improvement to database indexes. We are expecting a significant performance improvement for all cascading delete operations. We’re monitoring and will probably see some results in an hour.
Posted Apr 05, 2019 - 12:05 UTC
Identified
We identified where the issue is and we are working on a fix! Thanks for bearing with us :)
Posted Apr 05, 2019 - 10:03 UTC
Investigating
We are currently working on fixing an issue we found about seeing elevated error rates for some database operations. Deleting features/components, moving columns and doing other normal actions in productboard may not be completed or resulting in loading bar. Thanks for your patience while we investigate this!
Posted Apr 05, 2019 - 08:59 UTC