We are currently experiencing some technical difficulties with respect to task sidebar on features board for some users. We apologize for any inconvenience caused and we are working on resolving this issue momentarily.
Incident Report for Productboard
Resolved
This incident has been resolved.
Posted Oct 27, 2020 - 22:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2020 - 21:58 UTC
This incident affected: Web application.