Productboard not loading

Incident Report for Productboard

Resolved

This incident has been resolved; you are now able to load Productboard. We apologise for the inconvenience caused, and appreciate your patience, empathy and understanding as we worked to fix this issue.
Posted May 07, 2025 - 11:39 UTC

Investigating

Productboard is currently not able to load. We are investigating this issue and shall update this status page when we have an update.
Posted May 07, 2025 - 11:26 UTC
This incident affected: Web application.