Insights disappearing from features
Incident Report for Productboard
Resolved
The issue was promptly fixed. Thanks so much for bearing with us :)
Posted Dec 17, 2018 - 21:19 UTC
Investigating
We are currently experiencing some issues related to insights that may have disappeared from notes and features. We are investigating this and hopefully it will be solved soon! Sorry for the inconvenience
Posted Dec 17, 2018 - 21:06 UTC