Platform issues
Incident Report for productboard
Resolved
Servers are back up and running! Apologies for the inconvenience.
Posted Sep 24, 2019 - 21:37 UTC
Investigating
Hi productboarders! We are currently investigating some issues with our servers. We will keep you updated on our progress here!
Posted Sep 24, 2019 - 21:27 UTC