Provisioning Degraded Performance Impacting New Signups
Incident Report for Productboard
Resolved
This incident has been resolved.
Posted Aug 20, 2024 - 20:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2024 - 19:46 UTC
Identified
Due to degraded performance in provisioning, new signups may experience issues accessing Productboard. We are actively working on resolving this, and we apologize for any inconvenience.
Posted Aug 20, 2024 - 18:50 UTC