Productboard Spark is unavailable

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 14:17 UTC

Investigating

Productboard Spark is currently unavailable for some of our customers. Our team is investigating the issue with third-party provider and working to restore service as quickly as possible. We will post an update shortly. We apologize for the disruption.
Posted Sep 14, 2026 - 13:26 UTC
This incident affected: Spark AI.