Main Navigation is Down

Incident Report for Productboard

Resolved

We are pleased to confirm that the issue affecting the main navigation and Teamspace has now been resolved. All services should be fully operational.

Thank you for your patience and understanding while our team worked to address this incident.
Posted Jun 17, 2025 - 11:16 UTC

Identified

We have mitigated the incident.
Posted Jun 17, 2025 - 11:01 UTC

Investigating

We are currently investigating an issue affecting the main navigation and Teamspace. Users may be experiencing difficulty accessing these areas.

Our team is actively working to identify the root cause and restore full functionality. We will post another update on this page as soon as we have more information.

Thank you for your patience.
Posted Jun 17, 2025 - 10:29 UTC
This incident affected: Web application (Boards and data).