Login issues
Incident Report for productboard
Resolved
We are pleased to announce that the issue is now resolved. We thank you for your patience and understanding.
Posted Mar 02, 2020 - 13:33 UTC
Investigating
Hi everyone, productboard team is investigating login issues. We will keep you updated. In the meantime, the workaround is to use password auth if available. Thanks!
Posted Mar 02, 2020 - 13:18 UTC