Degraded Productboard performance
Incident Report for productboard
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 17:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 29, 2021 - 17:09 UTC
Investigating
We are experiencing some technical difficulties at this time. Please bear with us as we resolve this issue. We will keep you posted as soon as we hear more details.
We appreciate your patience and apologize for the inconvenience this may have caused you and your team.
Posted Mar 29, 2021 - 16:43 UTC
This incident affected: Web application.