Public Roadmaps Not Loading Features

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Mar 20, 2023 - 20:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 20, 2023 - 20:00 UTC

Identified

We’re receiving reports of trouble using Public Roadmaps as of 2.30 UTC. We’re on the case and will provide another update once we have more details to share. We’re sorry for the inconvenience.
Posted Mar 20, 2023 - 20:00 UTC
This incident affected: Web application.