We are currently experiencing some technical issues. We apologise for any inconveniences caused and are working on resolving the issue

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Oct 05, 2020 - 14:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 05, 2020 - 14:31 UTC

Investigating

We are currently investigating this issue.
Posted Oct 05, 2020 - 14:05 UTC
This incident affected: Web application (Boards and data).