Service disruption affecting workspace creation and Jira integration push

Incident Report for Productboard

Resolved

The issue has been resolved. Prior workspaces that had not yet provisioned are now processed making them accessible. Pushing Productboard entities to Jira functions as expected.
Posted Aug 18, 2025 - 20:17 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Aug 18, 2025 - 19:50 UTC

Identified

We’ve identified the root cause and are actively working on a solution. Certain actions in Productboard as mentioned may not be available in the meantime. We will post another update on this page as soon as we have more information and appreciate your continued patience.
Posted Aug 18, 2025 - 19:28 UTC

Investigating

We’re currently investigating an issue that may cause errors for new users creating workspaces and attempts to push newly created Productboard entities to Jira. We’ll share more details as soon as we have them.
Posted Aug 18, 2025 - 19:14 UTC
This incident affected: API and integrations and Website (www.productboard.com).