Productboard not loading
Incident Report for Productboard
Resolved
We can confirm the initial issue has now been resolved and everything should be back to normal. Apologies for any inconvenience. If you're still running into trouble, please reach out to support@productboard.com.
Posted Feb 16, 2023 - 12:45 UTC
Update
Productboard was down from 11:39 CET to 12:06 CET. However, some customers might still experience issues because the DNS might be cached on their end.

We are conducting a thorough investigation into all aspects of the service. Thank you for bearing with us.
Posted Feb 16, 2023 - 11:22 UTC
Monitoring
The incident has been mitigated and the team have pushed a fix.
Some customers may have to clear their cache and refresh the page before this fix is available. There could be a slight delay for some customers, we appreciate your patience while we resolve this.
Posted Feb 16, 2023 - 11:10 UTC
Identified
We have identified the issue and our team is working on a fix. We hope to get things back to normal as soon as possible. We will share an update soon.
Posted Feb 16, 2023 - 11:03 UTC
Investigating
We are experiencing an issue that is stopping Productboard from loading. We're currently investigating the issue and will provide a status update once we have more information. Apologies for the inconvenience.
Posted Feb 16, 2023 - 10:51 UTC
This incident affected: Web application.