Delay in creating features boards and roadmaps when using the new navigation
Incident Report for Productboard
Resolved
This is now working as expected with the fix that was pushed out, and you should once more be able to create feature boards and roadmaps as normal.

If you are still encountering issues, please reach out to support@productboard.com. Thank you for bearing with us.
Posted May 31, 2023 - 10:42 UTC
Monitoring
We have identified an issue with the creation of new boards and roadmaps for customers using the new navigation. Customers see very long delays with this when creating or duplicating both feature and roadmap boards.

The team have pushed a fix for this issue and are monitoring the situation. We'll share an update soon.
Posted May 31, 2023 - 08:20 UTC
This incident affected: Web application.