The Product Hierarchy API is currently experiencing timeout issues.

Incident Report for Productboard

Resolved

The issue has been resolved. APIs are fully operational.
Posted Aug 08, 2025 - 07:49 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Aug 08, 2025 - 01:21 UTC

Update

We are continuing to work on a fix for the issue.
Posted Aug 08, 2025 - 00:17 UTC

Identified

We’ve identified the root cause and are actively working on a fix.
Posted Aug 07, 2025 - 23:31 UTC

Investigating

We’re currently investigating an issue that may cause timeouts when updating custom fields using our product hierarchy API. We’ll share more details as soon as we have them.
Posted Aug 07, 2025 - 22:57 UTC
This incident affected: API and integrations.