Insights Page down
Incident Report for Productboard
Resolved
This incident has been resolved.
Posted Dec 19, 2022 - 16:22 UTC
Monitoring
The insights are back, we are currently investigating the cause of this issue still.
Posted Dec 19, 2022 - 16:08 UTC
Investigating
All insights have disappeared; our engineers are working on this as we speak - we will update this page as we investigate.

Thank you for your patience and understanding during this time, we are working to get a resumed service as fast as we can.
Posted Dec 19, 2022 - 16:00 UTC
This incident affected: Web application and Integrations & APIs.