Productboard is unavailable

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 14:55 UTC

Monitoring

Productboard is online again. The issue is being monitored by our team
Posted Feb 13, 2026 - 13:41 UTC

Investigating

Productboard is unavailable at the moment. You're likely to see an "Oops, something has gone wrong!" upon opening any page. We're investigating it.
Posted Feb 13, 2026 - 13:30 UTC
This incident affected: Web application (Boards and data, Teamspaces, Insights and AI, Identity and access).